re = /\$(?<type>[c|n]\d?)(?:\{(?<ranges>[^}]+)\})?/
str = 'B$c{A|D-I}$n{1-8}$c3{A-W}$n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end