package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$(?<type>[c|n]\d?)(?:\{(?<ranges>[^}]+)\})?`)
var str = `B$c{A|D-I}$n{1-8}$c3{A-W}$n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}