using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(?<type>[c|n]\d?)(?:\{(?<ranges>[^}]+)\})?";
string input = @"B$c{A|D-I}$n{1-8}$c3{A-W}$n";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}