$re = '/\$(?<type>[c|n]\d?)(?:\{(?<ranges>[^}]+)\})?/';
$str = 'B$c{A|D-I}$n{1-8}$c3{A-W}$n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);