re = /^((?!\.)[\w\d](?!.*\.\.)[a-zA-Z0-9\.!#$%&'*+\-\/=?^_`{|}~]*[^\.\s])@([a-zA-Z][a-zA-Z\d-]+[a-zA-Z\d]+\.)+[a-zA-Z]{2,6}$/m
str = 'contact@regex101.com'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result