$re = '/^((?!\.)[\w\d](?!.*\.\.)[a-zA-Z0-9\.!#$%&\'*+\-\/=?^_`{|}~]*[^\.\s])@([a-zA-Z][a-zA-Z\d-]+[a-zA-Z\d]+\.)+[a-zA-Z]{2,6}$/m';
$str = 'contact@regex101.com';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;