# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?!\.)[\w\d](?!.*\.\.)[a-zA-Z0-9\.!#$%&'*+\-\\/=?^_`{|}~]*[^\.\s])@([a-zA-Z][a-zA-Z\d-]+[a-zA-Z\d]+\.)+[a-zA-Z]{2,6}$/-/gm;t' <<< "contact@regex101.com"