const regex = /("\s+|^[\w\s\w])|(\s+")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("\\s+|^[\\w\\s\\w])|(\\s+")', 'gm')
const str = `{"name":" won",addr:" seoul 2 ","age": 2}`;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);