// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\%(\w+(-|_)?(\w+)?)\%)+").unwrap();
let string = "<div class=\"%class_name%\">
This is my pet %breed% and it is %age% years old and has a %best-friend% named %friendName%.
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}