re = /(\%(\w+(-|_)?(\w+)?)\%)+/
str = '<div class="%class_name%">
This is my pet %breed% and it is %age% years old and has a %best-friend% named %friendName%.
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end