const regex = /(\%(\w+(-|_)?(\w+)?)\%)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\%(\\w+(-|_)?(\\w+)?)\\%)+', 'g')
const str = `<div class="%class_name%">
This is my pet %breed% and it is %age% years old and has a %best-friend% named %friendName%.
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}