package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\%(\w+(-|_)?(\w+)?)\%)+`)
var str = `<div class="%class_name%">
This is my pet %breed% and it is %age% years old and has a %best-friend% named %friendName%.
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}