// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9\h/\\?:().,'+-]+$").unwrap();
let string = "slash/
minus-
questionmark?
twopoint:
openparenthesis(
closeparenthesis)
point.
comma,
simplequote'
plus+
SPACE
azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , ' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfgh\\\\jklmwxcvbn/ - ? : ( ) . , ' +
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}