$re = '/^[a-zA-Z0-9\h/\\\\?:().,\'+-]+$/m';
$str = 'slash/
minus-
questionmark?
twopoint:
openparenthesis(
closeparenthesis)
point.
comma,
simplequote\'
plus+
SPACE
azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , \' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfgh\\\\jklmwxcvbn/ - ? : ( ) . , \' +
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);