using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9\h/\\?:().,'+-]+$";
string input = @"slash/
minus-
questionmark?
twopoint:
openparenthesis(
closeparenthesis)
point.
comma,
simplequote'
plus+
SPACE
azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , ' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfgh\\jklmwxcvbn/ - ? : ( ) . , ' +
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}