import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9\\h/\\\\?:().,'+-]+$";
final String string = "slash/\n"
+ "minus-\n"
+ "questionmark?\n"
+ "twopoint:\n"
+ "openparenthesis(\n"
+ "closeparenthesis)\n"
+ "point.\n"
+ "comma,\n"
+ "simplequote'\n"
+ "plus+\n"
+ "SPACE \n"
+ "azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN \n"
+ "azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , ' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN\n"
+ "azertyuiopqsdfgh\\\\jklmwxcvbn/ - ? : ( ) . , ' +\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}