import Foundation
let pattern = #"uRD.+Accept\s+\d{2},\d{2},\d{2},rc=\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00
03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)