use strict;
my $str = '03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00
03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00';
my $regex = qr/uRD.+Accept\s+\d{2},\d{2},\d{2},rc=\d+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}