const regex = new RegExp('uRD.+Accept\\s+\\d{2},\\d{2},\\d{2},rc=\\d+', 'g')
const str = `03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00
03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}