re = /uRD.+Accept\s+\d{2},\d{2},\d{2},rc=\d+/
str = '03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00
03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end