$re = '/^(?P<protocol>[a-z\-]+)?:?(?P<host>\/\/.*\.[^\/]+)$/m';
$str = 'https://example.domain
http://example.domain
//example.domain
//example.com
https://example.com:34
//example.com:23
example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);