const regex = /^(?P<protocol>[a-z\-]+)?:?(?P<host>\/\/.*\.[^\/]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<protocol>[a-z\\-]+)?:?(?P<host>\\\/\\\/.*\\.[^\\\/]+)$', 'gm')
const str = `https://example.domain
http://example.domain
//example.domain
//example.com
https://example.com:34
//example.com:23
example.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}