package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<protocol>[a-z\-]+)?:?(?P<host>\/\/.*\.[^\/]+)$`)
var str = `https://example.domain
http://example.domain
//example.domain
//example.com
https://example.com:34
//example.com:23
example.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}