#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<protocol>[a-z\-]+)?:?(?P<host>\/\/.*\.[^\/]+)$"
Local $sString = "https://example.domain" & @CRLF & _
"http://example.domain" & @CRLF & _
"//example.domain" & @CRLF & _
"//example.com" & @CRLF & _
"https://example.com:34" & @CRLF & _
"//example.com:23" & @CRLF & _
"example.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")