re = /^[a-z]\w*$/m
str = 'dasdasdasd
askdhka102131a
#asdaw4324\\
-asds
1
asdasd
1212
adqweqwqqeqwe
asdasd
asdasd123123123
1233adasdsad
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end