$re = '/^[a-z]\w*$/m';
$str = 'dasdasdasd
askdhka102131a
#asdaw4324\\
-asds
1
asdasd
1212
adqweqwqqeqwe
asdasd
asdasd123123123
1233adasdsad
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);