package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]\w*$`)
var str = `dasdasdasd
askdhka102131a
#asdaw4324\
-asds
1
asdasd
1212
adqweqwqqeqwe
asdasd
asdasd123123123
1233adasdsad
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}