#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]\w*$"
Local $sString = "dasdasdasd" & @CRLF & _
"askdhka102131a" & @CRLF & _
"#asdaw4324\" & @CRLF & _
"-asds" & @CRLF & _
"1" & @CRLF & _
"asdasd" & @CRLF & _
"1212" & @CRLF & _
"adqweqwqqeqwe" & @CRLF & _
"asdasd" & @CRLF & _
"asdasd123123123" & @CRLF & _
"1233adasdsad" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")