re = /( `\n)( query \{\n)( .*)(\{\n)( (.|\n|)[^;]*)( \}\n)( \}\n)( `)/m
str = 'import { gql } from \'@apollo/client\';
const getAccountingSubject = gql(
`
query {
accountingSubjects {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
`,
);
const getAccountingSubjectById = (id) =>
gql(
`
query {
accountingSubjects (where: {id: {eq: ${id}}}) {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
`,
);
export default {
getAccountingSubject,
getAccountingSubjectById,
};
'
subst = '$1$2$3{\\n totalCount\\n pageInfo {\\n hasNextPage\\n hasPreviousPage\\n }\\n item $4 $5 }\\n$7$8$9'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result