# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"( `\n)( query \{\n)( .*)(\{\n)( (.|\n|)[^;]*)( \}\n)( \}\n)( `)"
test_str = ("import { gql } from '@apollo/client';\n\n"
"const getAccountingSubject = gql(\n"
" `\n"
" query {\n"
" accountingSubjects {\n"
" id\n"
" accountingSubjectNumber\n"
" accountingSubjectTypeId\n"
" accountingSubjectType {\n"
" name\n"
" code\n"
" }\n"
" accountingSubjectPrefixCodeId\n"
" accountingSubjectCompanyType\n"
" name\n"
" note\n"
" }\n"
" }\n"
" `,\n"
");\n\n"
"const getAccountingSubjectById = (id) =>\n"
" gql(\n"
" `\n"
" query {\n"
" accountingSubjects (where: {id: {eq: ${id}}}) {\n"
" id\n"
" accountingSubjectNumber\n"
" accountingSubjectTypeId\n"
" accountingSubjectType {\n"
" name\n"
" code\n"
" }\n"
" accountingSubjectPrefixCodeId\n"
" accountingSubjectCompanyType\n"
" name\n"
" note\n"
" }\n"
" }\n"
" `,\n"
" );\n\n"
"export default {\n"
" getAccountingSubject,\n"
" getAccountingSubjectById,\n"
"};\n")
subst = "$1$2$3{\\n totalCount\\n pageInfo {\\n hasNextPage\\n hasPreviousPage\\n }\\n item $4 $5 }\\n$7$8$9"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.