using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( `\n)( query \{\n)( .*)(\{\n)( (.|\n|)[^;]*)( \}\n)( \}\n)( `)";
string substitution = @"$1$2$3{\n totalCount\n pageInfo {\n hasNextPage\n hasPreviousPage\n }\n item $4 $5 }\n$7$8$9";
string input = @"import { gql } from '@apollo/client';
const getAccountingSubject = gql(
`
query {
accountingSubjects {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
`,
);
const getAccountingSubjectById = (id) =>
gql(
`
query {
accountingSubjects (where: {id: {eq: ${id}}}) {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
`,
);
export default {
getAccountingSubject,
getAccountingSubjectById,
};
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}