# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/( `\n)( query \{\n)( .*)(\{\n)( (.|\n|)[^;]*)( \}\n)( \}\n)( `)/$1$2$3{\n totalCount\n pageInfo {\n hasNextPage\n hasPreviousPage\n }\n item $4 $5 }\n$7$8$9/gm;t' <<< "import { gql } from '@apollo/client';
const getAccountingSubject = gql(
`
query {
accountingSubjects {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
`,
);
const getAccountingSubjectById = (id) =>
gql(
`
query {
accountingSubjects (where: {id: {eq: ${id}}}) {
id
accountingSubjectNumber
accountingSubjectTypeId
accountingSubjectType {
name
code
}
accountingSubjectPrefixCodeId
accountingSubjectCompanyType
name
note
}
}
`,
);
export default {
getAccountingSubject,
getAccountingSubjectById,
};
"