// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-\n([^(]+)(\(\d\))[|]([^-]+)").unwrap();
let string = "
--------------------------------------------------------------------------------
PHYS 11A GEN PHYS-MECHANICS (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
PHYS 11B GEN PHYS-HEAT,LIGHT,SOUND (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
PHYS 11C GEN PHYS-ELECT,MAG,MOD (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
MATH 30 CALCULUS I (4)|MATH 180 Single Variable (4)
| Calculus I
--------------------------------------------------------------------------------
MATH 31 CALCULUS II (4)|MATH 185 Single Variable (4)
| Calculus II
--------------------------------------------------------------------------------
MATH 32 CALCULUS III (4)|MATH 280 Intermediate Calculus (4)
--------------------------------------------------------------------------------
MATH 45 DIFFERNTL EQUATN SCI+ENGR (3)|MATH 295 Differential Equations (3)
| ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}