const regex = /-\n([^(]+)(\(\d\))[|]([^-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\n([^(]+)(\\(\\d\\))[|]([^-]+)', 'gm')
const str = `
--------------------------------------------------------------------------------
PHYS 11A GEN PHYS-MECHANICS (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
PHYS 11B GEN PHYS-HEAT,LIGHT,SOUND (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
PHYS 11C GEN PHYS-ELECT,MAG,MOD (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
MATH 30 CALCULUS I (4)|MATH 180 Single Variable (4)
| Calculus I
--------------------------------------------------------------------------------
MATH 31 CALCULUS II (4)|MATH 185 Single Variable (4)
| Calculus II
--------------------------------------------------------------------------------
MATH 32 CALCULUS III (4)|MATH 280 Intermediate Calculus (4)
--------------------------------------------------------------------------------
MATH 45 DIFFERNTL EQUATN SCI+ENGR (3)|MATH 295 Differential Equations (3)
| `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}