import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-\\n([^(]+)(\\(\\d\\))[|]([^-]+)";
final String string = "\n"
+ "--------------------------------------------------------------------------------\n"
+ "PHYS 11A GEN PHYS-MECHANICS (4)|NOT ARTICULATED \n"
+ "--------------------------------------------------------------------------------\n"
+ "PHYS 11B GEN PHYS-HEAT,LIGHT,SOUND (4)|NOT ARTICULATED \n"
+ "--------------------------------------------------------------------------------\n"
+ "PHYS 11C GEN PHYS-ELECT,MAG,MOD (4)|NOT ARTICULATED \n"
+ "--------------------------------------------------------------------------------\n"
+ "MATH 30 CALCULUS I (4)|MATH 180 Single Variable (4)\n"
+ " | Calculus I \n"
+ "--------------------------------------------------------------------------------\n"
+ "MATH 31 CALCULUS II (4)|MATH 185 Single Variable (4)\n"
+ " | Calculus II \n"
+ "--------------------------------------------------------------------------------\n"
+ "MATH 32 CALCULUS III (4)|MATH 280 Intermediate Calculus (4)\n"
+ "--------------------------------------------------------------------------------\n"
+ "MATH 45 DIFFERNTL EQUATN SCI+ENGR (3)|MATH 295 Differential Equations (3)\n"
+ " | ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}