use strict;
my $str = '
--------------------------------------------------------------------------------
PHYS 11A GEN PHYS-MECHANICS (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
PHYS 11B GEN PHYS-HEAT,LIGHT,SOUND (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
PHYS 11C GEN PHYS-ELECT,MAG,MOD (4)|NOT ARTICULATED
--------------------------------------------------------------------------------
MATH 30 CALCULUS I (4)|MATH 180 Single Variable (4)
| Calculus I
--------------------------------------------------------------------------------
MATH 31 CALCULUS II (4)|MATH 185 Single Variable (4)
| Calculus II
--------------------------------------------------------------------------------
MATH 32 CALCULUS III (4)|MATH 280 Intermediate Calculus (4)
--------------------------------------------------------------------------------
MATH 45 DIFFERNTL EQUATN SCI+ENGR (3)|MATH 295 Differential Equations (3)
| ';
my $regex = qr/-\n([^(]+)(\(\d\))[|]([^-]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}