import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^rgba?\\((?:(?:(?:[0-9]{1,3} ){2}[0-9]{1,3}|(?:[0-9]{1,3}% ){2}[0-9]{1,3}%)(?: \\/ (?:[0-9]{1,3}%|1|0|0?\\.[0-9]+))?|(?:(?:[0-9]{1,3}, ){2}[0-9]{1,3}|(?:[0-9]{1,3}%, ){2}[0-9]{1,3}%)(?:, (?:[0-9]{1,3}%|1|0|0?\\.[0-9]+))?)\\)$";
final String string = "// invalid\n"
+ "rgb()\n"
+ "rgba()\n"
+ "rgb(123)\n"
+ "rgb(11 22 )\n"
+ "rgb(11 22 2 / 03)\n"
+ "rgb(11 22 2 / 10)\n"
+ "rgb(1 2 3 / 0.34%)\n"
+ "rgb(11% 22 33)\n"
+ "rgb(111 222% 333)\n"
+ "rgb(1 22 333 )\n"
+ "rgb(1 2 3, 1)\n"
+ "rgb(1 2, 3 / 1)\n"
+ "// valid\n"
+ "rgb(111 22 333)\n"
+ "rgb(1 2 3)\n"
+ "rgb(11 22 33)\n"
+ "rgb(111 222 333)\n"
+ "rgb(1 22 333)\n"
+ "rgb(1 2 3 / 1)\n"
+ "rgb(11 22 2 / 0)\n"
+ "rgb(1 2 3 / 0.34)\n"
+ "rgb(1 2 3 / .34)\n"
+ "rgb(1 2 3 / 0.34)\n"
+ "rgb(1 2 3 / 1%)\n"
+ "rgb(1 2 3 / 10%)\n"
+ "rgb(1 2 3 / 100%)\n"
+ "rgb(11 22 2 / 0%)\n"
+ "rgb(1 2 3 / 34%)\n"
+ "rgb(1 2 3 / 4%)\n"
+ "rgb(111 22 333)\n"
+ "rgb(1% 2% 3%)\n"
+ "rgb(11% 22% 2% / 0)\n"
+ "rgb(12%, 0%, 100%)\n"
+ "rgb(111, 22, 333)\n"
+ "rgb(1, 2, 3)\n"
+ "rgb(1, 2, 3, 1)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}