package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^rgba?\((?:(?:(?:[0-9]{1,3} ){2}[0-9]{1,3}|(?:[0-9]{1,3}% ){2}[0-9]{1,3}%)(?: \/ (?:[0-9]{1,3}%|1|0|0?\.[0-9]+))?|(?:(?:[0-9]{1,3}, ){2}[0-9]{1,3}|(?:[0-9]{1,3}%, ){2}[0-9]{1,3}%)(?:, (?:[0-9]{1,3}%|1|0|0?\.[0-9]+))?)\)$`)
var str = `// invalid
rgb()
rgba()
rgb(123)
rgb(11 22 )
rgb(11 22 2 / 03)
rgb(11 22 2 / 10)
rgb(1 2 3 / 0.34%)
rgb(11% 22 33)
rgb(111 222% 333)
rgb(1 22 333 )
rgb(1 2 3, 1)
rgb(1 2, 3 / 1)
// valid
rgb(111 22 333)
rgb(1 2 3)
rgb(11 22 33)
rgb(111 222 333)
rgb(1 22 333)
rgb(1 2 3 / 1)
rgb(11 22 2 / 0)
rgb(1 2 3 / 0.34)
rgb(1 2 3 / .34)
rgb(1 2 3 / 0.34)
rgb(1 2 3 / 1%)
rgb(1 2 3 / 10%)
rgb(1 2 3 / 100%)
rgb(11 22 2 / 0%)
rgb(1 2 3 / 34%)
rgb(1 2 3 / 4%)
rgb(111 22 333)
rgb(1% 2% 3%)
rgb(11% 22% 2% / 0)
rgb(12%, 0%, 100%)
rgb(111, 22, 333)
rgb(1, 2, 3)
rgb(1, 2, 3, 1)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}