#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^rgba?\((?:(?:(?:[0-9]{1,3} ){2}[0-9]{1,3}|(?:[0-9]{1,3}% ){2}[0-9]{1,3}%)(?: \/ (?:[0-9]{1,3}%|1|0|0?\.[0-9]+))?|(?:(?:[0-9]{1,3}, ){2}[0-9]{1,3}|(?:[0-9]{1,3}%, ){2}[0-9]{1,3}%)(?:, (?:[0-9]{1,3}%|1|0|0?\.[0-9]+))?)\)$"
Local $sString = "// invalid" & @CRLF & _
"rgb()" & @CRLF & _
"rgba()" & @CRLF & _
"rgb(123)" & @CRLF & _
"rgb(11 22 )" & @CRLF & _
"rgb(11 22 2 / 03)" & @CRLF & _
"rgb(11 22 2 / 10)" & @CRLF & _
"rgb(1 2 3 / 0.34%)" & @CRLF & _
"rgb(11% 22 33)" & @CRLF & _
"rgb(111 222% 333)" & @CRLF & _
"rgb(1 22 333 )" & @CRLF & _
"rgb(1 2 3, 1)" & @CRLF & _
"rgb(1 2, 3 / 1)" & @CRLF & _
"// valid" & @CRLF & _
"rgb(111 22 333)" & @CRLF & _
"rgb(1 2 3)" & @CRLF & _
"rgb(11 22 33)" & @CRLF & _
"rgb(111 222 333)" & @CRLF & _
"rgb(1 22 333)" & @CRLF & _
"rgb(1 2 3 / 1)" & @CRLF & _
"rgb(11 22 2 / 0)" & @CRLF & _
"rgb(1 2 3 / 0.34)" & @CRLF & _
"rgb(1 2 3 / .34)" & @CRLF & _
"rgb(1 2 3 / 0.34)" & @CRLF & _
"rgb(1 2 3 / 1%)" & @CRLF & _
"rgb(1 2 3 / 10%)" & @CRLF & _
"rgb(1 2 3 / 100%)" & @CRLF & _
"rgb(11 22 2 / 0%)" & @CRLF & _
"rgb(1 2 3 / 34%)" & @CRLF & _
"rgb(1 2 3 / 4%)" & @CRLF & _
"rgb(111 22 333)" & @CRLF & _
"rgb(1% 2% 3%)" & @CRLF & _
"rgb(11% 22% 2% / 0)" & @CRLF & _
"rgb(12%, 0%, 100%)" & @CRLF & _
"rgb(111, 22, 333)" & @CRLF & _
"rgb(1, 2, 3)" & @CRLF & _
"rgb(1, 2, 3, 1)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")