$re = '/^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$/m';
$str = '1a2b3cd2312321
12q32131231231f
32132131231231231231221
aa
12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw
12222a22333fw342434234234weqweqw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);