const regex = /^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$', 'gm')
const str = `1a2b3cd2312321
12q32131231231f
32132131231231231231221
aa
12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw
12222a22333fw342434234234weqweqw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}