import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$";
final String string = "1a2b3cd2312321\n"
+ "12q32131231231f\n"
+ "32132131231231231231221\n"
+ "aa\n"
+ "12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw\n"
+ "12222a22333fw342434234234weqweqw";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}