#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=([0-9]*[a-z]){2,})([a-zA-Z0-9]{8,32})$"
Local $sString = "1a2b3cd2312321" & @CRLF & _
"12q32131231231f" & @CRLF & _
"32132131231231231231221" & @CRLF & _
"aa" & @CRLF & _
"12222a22333fw342434234234weqweqweqweqweqweqweqweqweqweqweqweqwewqeqweqwewqeqweqweqweqweqw" & @CRLF & _
"12222a22333fw342434234234weqweqw"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")