use strict;
my $str = 'root/1-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/mpt_statistics_period/absolute/net/maximum_drawdown
root/3-825-ReturnAndStatsCompositeAPI[v="customDate-index",g="customDate",p="{"column":"column1","asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns_period/net/cumulative
root/6-825-ReturnAndStatsCompositeAPI[v="customDate-benchmark",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_period/relative/net/bear_alpha
';
my $regex = qr/\S+\[v=\"(customDate)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+\/(returns_period|mpt_statistics_period\/\w+)\/(\w+)\/(\w+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}