const regex = /\S+\[v=\"(customDate)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+\/(returns_period|mpt_statistics_period\/\w+)\/(\w+)\/(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+\\[v=\\"(customDate)-(\\w+)\\",g=\\"(\\w+)\\",p=\\"(\\S+)\\"\\]\\S+\\\/(returns_period|mpt_statistics_period\\\/\\w+)\\\/(\\w+)\\\/(\\w+)', 'g')
const str = `root/1-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/mpt_statistics_period/absolute/net/maximum_drawdown
root/3-825-ReturnAndStatsCompositeAPI[v="customDate-index",g="customDate",p="{"column":"column1","asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns_period/net/cumulative
root/6-825-ReturnAndStatsCompositeAPI[v="customDate-benchmark",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_period/relative/net/bear_alpha
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}