#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+\[v=\"(customDate)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+\/(returns_period|mpt_statistics_period\/\w+)\/(\w+)\/(\w+)"
Local $sString = "root/1-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/mpt_statistics_period/absolute/net/maximum_drawdown" & @CRLF & _
"" & @CRLF & _
"root/3-825-ReturnAndStatsCompositeAPI[v="customDate-index",g="customDate",p="{"column":"column1","asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns_period/net/cumulative" & @CRLF & _
"" & @CRLF & _
"root/6-825-ReturnAndStatsCompositeAPI[v="customDate-benchmark",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_period/relative/net/bear_alpha" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")