import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\[v=\\\"(customDate)-(\\w+)\\\",g=\\\"(\\w+)\\\",p=\\\"(\\S+)\\\"\\]\\S+\\/(returns_period|mpt_statistics_period\\/\\w+)\\/(\\w+)\\/(\\w+)";
final String string = "root/1-825-ReturnAndStatsCompositeAPI[v=\"customDate-return\",g=\"customDate\",p=\"{\"asOfDate\":\"2016-12-31\",\"startDate\":\"2016-05-31\"}\"]/data/share_classes/array[1]/returns_period/net/cumulative\n\n\n"
+ "root/2-825-ReturnAndStatsCompositeAPI[v=\"customDate-return\",g=\"customDate\",p=\"{\"column\":\"column2\",\"asOfDate\":\"2016-05-31\",\"startDate\":\"2016-01-31\"}\"]/data/share_classes/array[1]/returns_period/net/cumulative\n\n\n"
+ "root/2-825-ReturnAndStatsCompositeAPI[v=\"customDate-return\",g=\"customDate\",p=\"{\"column\":\"column2\",\"asOfDate\":\"2016-05-31\",\"startDate\":\"2016-01-31\"}\"]/data/share_classes/array[1]/mpt_statistics_period/absolute/net/maximum_drawdown\n\n"
+ "root/3-825-ReturnAndStatsCompositeAPI[v=\"customDate-index\",g=\"customDate\",p=\"{\"column\":\"column1\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2016-05-31\"}\"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns_period/net/cumulative\n\n"
+ "root/6-825-ReturnAndStatsCompositeAPI[v=\"customDate-benchmark\",g=\"customDate\",p=\"{\"column\":\"column2\",\"asOfDate\":\"2016-05-31\",\"startDate\":\"2016-01-31\"}\"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_period/relative/net/bear_alpha\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}