# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([SGMRHDAWN0-9]{1,11})$"
test_str = ("918364\n"
"S122 - 19280\n"
"53742584\n"
"M415\n"
"211.2233.22\n"
"M415R\n"
"G15690\n"
"51168081\n"
"51168081\n"
"93453935\n"
"79676246\n"
"13600235\n"
"M3900301\n"
"230138859\n"
"71133713\n"
"4249790\n"
"207570\n"
"207570\n"
"934259\n"
"3296851\n"
"20921057\n"
"00709199\n"
"90549079\n"
"61001358\n"
"DAWN\n"
"10140332\n"
"2R5-5611\n"
"1000853235\n"
"17H383573 \n"
"164778157\n"
"287353\n"
"93388870")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.