package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([SGMRHDAWN0-9]{1,11})$`)
var str = `918364
S122 - 19280
53742584
M415
211.2233.22
M415R
G15690
51168081
51168081
93453935
79676246
13600235
M3900301
230138859
71133713
4249790
207570
207570
934259
3296851
20921057
00709199
90549079
61001358
DAWN
10140332
2R5-5611
1000853235
17H383573
164778157
287353
93388870`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}