const regex = new RegExp('^([SGMRHDAWN0-9]{1,11})$', 'gm')
const str = `918364
S122 - 19280
53742584
M415
211.2233.22
M415R
G15690
51168081
51168081
93453935
79676246
13600235
M3900301
230138859
71133713
4249790
207570
207570
934259
3296851
20921057
00709199
90549079
61001358
DAWN
10140332
2R5-5611
1000853235
17H383573
164778157
287353
93388870`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}